pyTivo Discussion Forum Forum Index pyTivo Discussion Forum
Answers and the development of pyTivo a TiVo transcoding server
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

TiVo dropping shared folder

 
Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support
 View previous topic :: View next topic  
Author Message
bpric



Joined: 14 May 2010
Posts: 1

PostPosted: Fri May 14, 2010 2:50 pm    Post subject: TiVo dropping shared folder Reply with quote

I've been using PyTivo (on a mac) to share a folder on a Buffalo NAS for several months and all has been great for the most part. The one problem that I have is that the shared folder often gets dropped from the TiVo menu. I don't really know what events lead up to it getting dropped, but I can usually get it to reappear if I do some sort of nominal activity in the shared folder like rename a file. Sometimes the shared folder is found, but TiVo thinks that it's empty. And other sometimes the folder is there, but recently added files don't show up on the menu.
Is there a way to get the TiVo to stay more up-to-date with respect to the shared file?
Thanks in advance,
Bryan
Back to top
View user's profile Send private message
philhu



Joined: 04 Jan 2008
Posts: 819
Location: Boston, MA

PostPosted: Fri May 14, 2010 6:06 pm    Post subject: Reply with quote

I have never seen this on my Buffalo

I run 4 folders on it and they just work, never see anything unsynchronized

Are you in a Windows environment? Because I have seen this kind of problem when a user runs a WINS server and the Wins server gets flakey.

WINS is used by Windows to resolve local machine names. Most do not run a WINS server, but if you are, that could be it
Back to top
View user's profile Send private message
wmcbrine



Joined: 04 Jan 2008
Posts: 2627
Location: Maryland

PostPosted: Fri May 14, 2010 9:01 pm    Post subject: Reply with quote

bpric, that actually sounds like three different and unrelated problems. The share disappearing altogether happens when Zeroconf packets go missing for some reason -- most often, when you have a WiFi link, either on the server or the TiVo end. Some firewalls also seem to be a problem. The shares should reappear by themselves eventually, but if not, you can get them back by restarting pyTivo. If you're desperate, you could disable Zeroconf and see if that helps.

For the empty shares, I'd want to see pyTivo's log to diagnose that. My guess is that you'd see an exception being thrown at that point, for whatever reason.

Recently added files not showing up could be a caching issue, but I'd want more details. Make sure you're running the latest version of pyTivo.

Consider running pyTivo directly on your NAS, instead of on the Mac pointing to the NAS.

_________________
My pyTivo fork . My page
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Site is in NO WAY affiliated with TiVo Inc

Powered by phpBB © 2001, 2005 phpBB Group
phpBB SEO

Get pytivo at SourceForge.net. Fast, secure and Free Open Source software downloads
[ Time: 0.0697s ][ Queries: 12 (0.0080s) ][ GZIP on - Debug on ]