pyTivo Discussion Forum Forum Index pyTivo Discussion Forum
Answers and the development of pyTivo a TiVo transcoding server
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Subdirectory Problem After Hard Drive Upgrade - SOLVED!

Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support
 View previous topic :: View next topic  
Author Message

Joined: 05 Dec 2008
Posts: 9

PostPosted: Thu Dec 31, 2009 5:43 am    Post subject: Subdirectory Problem After Hard Drive Upgrade - SOLVED! Reply with quote

When browsing my shares through the Now Playing List I can go into a folder, but entering any folder below that presents the same list as the current folder:

> Comedy
> Drama
> Adventure
>> Comedy
>> Drama
>> Adventure
>>> Comedy
>>> Drama
>>> Adventure

...and it continues to repeat from there. Interestingly, in order to back out, I have to go back the same number of steps as I went in. I am able to browse the shares correctly through the web interface and can push videos from any subdirectory to the TiVo.

Some background:

The TiVo is a Series 2 Pioneer DVR-57H. A couple months back the hard drive failed so I set up an old 11.9GB drive (it's all I had on hand...) with InstantCake and have been running on that drive until today, getting by with pyTiVo and KMTTG to keep the drive as clear as possible.

Today I installed a 1TB SATA WD10EADS Western Digital Green drive, disabling the IntelliPark feature (this has been an issue reported at the TiVo Community forums) before setting it up with InstantCake. I am using a SATA>IDE adapter from Weaknees. I also removed the DVD drive since it stopped burning discs a couple years ago. I am thinking of trying to replace it with a second hard drive.

After completing the Guided Setup, getting guide data from TiVo, tweaking the settings, and adding my season passes I fired up pyTiVo (McBrine 2009-11-02) and right away noticed the problem. After fiddling with it a bit I decided to update to the latest release and installed McBrine's 2009-12-29 release, however I still have the problem of not being able to navigate subfolders...

My pyTiVo.conf is as follows:

tivo_password = XXXXXXXX
tivo_mak = XXXXXXXX
ffmpeg = E:\pyTivo\bin\ffmpeg.exe
tivodecode = E:\pyTivo\bin\tivodecode.exe
tdcat = E:\pyTivo\bin\tdcat.exe
beacon =
togo_path = G:\TiVo
tivo_username = XXXXXXXX
port = 9032

video_br = 896K
max_video_br = 1344K
audio_br = 128K
max_audio_br = 192K
audio_fr = 44100
audio_ch = 2
audio_codec = mp2


[Video Archive]
type = video
path = I:\public\Video
force_alpha = True

type = video
path = G:\TiVo
force_alpha = True

The beacon address in the Server section may look odd, but it is correct. My network is

Other than the problem navigating subfolders in my shares everything seems to be working as it should. Any thoughts? If some log or console information will help just let me know what to post.

Last edited by encryptedbytes on Thu Dec 31, 2009 4:31 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 12 Apr 2008
Posts: 1420

PostPosted: Thu Dec 31, 2009 6:46 am    Post subject: Reply with quote

I haven't used InstantCake, but it's possible that it put and older, though still compatible version of the Tivo software on your drive. IIRC, older Tivo software didn't deal with subfolder navigation well.

Force a couple of network connects and see if your Tivo will upgrade to the latest software. I have a hunch things will probably clear up once it does.
Back to top
View user's profile Send private message

Joined: 04 Jan 2008
Posts: 2623
Location: Maryland

PostPosted: Thu Dec 31, 2009 7:58 am    Post subject: Reply with quote

Seconded. This is what I'd expect to see on a TiVo with older software (between 8.3 and, what, 9.3? I forget).
My pyTivo fork . My page
Back to top
View user's profile Send private message Visit poster's website

Joined: 05 Dec 2008
Posts: 9

PostPosted: Thu Dec 31, 2009 4:30 pm    Post subject: Reply with quote

Well, it seems to be working fine now all on it's own. I haven't changed anything since I posted last night but the subfolders are working as they should now.

The current software version on the machine is 9.3.2b-01-2-275. I didn't note the version yesterday so I am not sure if it has changed, but I think I recall 9.3 being current.

Oddly, the last successful connection was yesterday afternoon, many hours before I last saw the problem. I can only guess that the TiVo fetched an update to the software but did not install it (or reboot?) until sometime in the night...

The InstantCake disc I used is only a couple months old, but it could have been put together long before that and contain an older version of the TiVo software as you suspect. Since nothing else has changed since I posted last night, I have to agree that this is the case. Thanks for your responses on my trouble, I think you called it right :C)

On a side note, the 1TB SATA drive with the SATA>IDE adapter seems to be working quite well and provides quite a lot of recording capacity:

Extreme (fine): 231 hours
High (sp): 445 hours
Medium (lp): 907 hours
Basic (ep): 1361 hours

The drive, having a lower spindle speed and drawing less power, is very quiet in the machine and is barely audible, even with a hole in the front of the unit where the DVD drive used to be. The old 11.9GB drive I had running in there could be heard across the room chugging and grinding away.

It is my understanding that the TiVo will not use drives greater than 1.1TB due to a limitation in the Linux kernel used in the TiVo, so I am at maximum capacity now unless I can install a second drive, but with my new capacity I really can't say I *need* to :C)

Without a SATA>IDE adapter the largest (IDE) drive you can install is 750GB. I am told that these are starting to get scarce and have noticed that they cost more than 1TB SATA drive and adapter.

The overall cost of the upgrade was:

1TB SATA Western Digital WD10EADS Green hard drive - $85
SATA>IDE adapter & IDE cable - $26
InstantCake - $20

For a total of $131. A comparable upgrade kit from is $239.00 and from Weaknees is $249. The upgrade kits come with pre-loaded drives of course, but for my efforts of setting up the drive myself (which is quite easy if you are technically inclined and only took about 30 minutes) I saved over $100 on the whole deal and have the bonus of still owning the InstantCake disc which I can use to set up drives in the future should I need to.

Anyway, I've rambled on long enough. Thanks again for your help. pytiVo has been an integral part of my Home Entertainment Contraption that I've thoroughly enjoyed over the last few years!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Site is in NO WAY affiliated with TiVo Inc

Powered by phpBB © 2001, 2005 phpBB Group

Get pytivo at Fast, secure and Free Open Source software downloads
[ Time: 0.0643s ][ Queries: 12 (0.0074s) ][ GZIP on - Debug on ]