pyTivo Discussion Forum Forum Index pyTivo Discussion Forum
Answers and the development of pyTivo a TiVo transcoding server
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Single Page Of Install Instructions

 
Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support
 View previous topic :: View next topic  
Author Message
skuban



Joined: 20 Apr 2010
Posts: 2

PostPosted: Tue Apr 20, 2010 8:15 pm    Post subject: Single Page Of Install Instructions Reply with quote

I love pyTivo but the windows install instructions are getting pretty hairy for new users.

The main install page refers to threads which refer to other threads and other files...

So here is all of the instructions and download links in one place: http://scottsoapbox.com/2010/04/20/pytivo-install-instructions/

Feel free to steal this and update the install page. I only used my blog because I didn't feel like fighting BBCode to format it.

Smile
Scott
Back to top
View user's profile Send private message
dlfl



Joined: 05 Jan 2008
Posts: 992
Location: Near Dayton, Ohio

PostPosted: Wed Apr 21, 2010 3:44 pm    Post subject: Reply with quote

Looks excellent to me. I added a note with a link to your instructions on the pyTiVo wiki install page.

If other users find fault with what I did, please correct it.

_________________
TiVo Roamio, Win 10 64bit, Wired Ethernet
Try metagenerator 3 and pyTivoMetaGen
VideoReDo users: try VAP
Back to top
View user's profile Send private message
skuban



Joined: 20 Apr 2010
Posts: 2

PostPosted: Fri May 07, 2010 12:52 pm    Post subject: Reply with quote

sweet. Smile
Back to top
View user's profile Send private message
brennok



Joined: 08 May 2010
Posts: 15

PostPosted: Mon May 10, 2010 2:56 am    Post subject: Reply with quote

I just wanted to say thanks this definitely helped.

The only thing I found which maybe is because I may have copied instead of moved the conf file is I had to copy my conf file back to C:\Users\Public\Documents\pyTivo based off this post.

It was driving me nuts since console worked but if I ran it as a service my shares were empty.
Back to top
View user's profile Send private message
rdian06



Joined: 12 Apr 2008
Posts: 1420

PostPosted: Mon May 10, 2010 2:12 pm    Post subject: Reply with quote

brennok wrote:
I just wanted to say thanks this definitely helped.

The only thing I found which maybe is because I may have copied instead of moved the conf file is I had to copy my conf file back to C:\Users\Public\Documents\pyTivo based off this post.

It was driving me nuts since console worked but if I ran it as a service my shares were empty.


This means you upgraded pyTivo incorrectly. wmcbrine's latest git code will NOT be able to find the conf file if it's in the public documents area. For the latest code you want ONE copy of the conf file and it must be in the pyTivo program folder.
Back to top
View user's profile Send private message
brennok



Joined: 08 May 2010
Posts: 15

PostPosted: Mon May 10, 2010 10:50 pm    Post subject: Reply with quote

Hmm I wonder what I did wrong then since services was the only mode it wasn't working in.

The only other thing I can think I did beside copying instead of move was the zip file of the update contained the wmcbrine folder so when I extracted it to Program Files\pyTivo\ it just added the contents in the wmcbrine folder and didn't overwrite it. I then moved everything out of that folder and into the pyTivo folder which then did overwrite everything.
Back to top
View user's profile Send private message
rdian06



Joined: 12 Apr 2008
Posts: 1420

PostPosted: Wed May 12, 2010 4:34 pm    Post subject: Reply with quote

brennok wrote:
Hmm I wonder what I did wrong then since services was the only mode it wasn't working in.

The only other thing I can think I did beside copying instead of move was the zip file of the update contained the wmcbrine folder so when I extracted it to Program Files\pyTivo\ it just added the contents in the wmcbrine folder and didn't overwrite it. I then moved everything out of that folder and into the pyTivo folder which then did overwrite everything.


Did you remember to shutdown pyTivo before doing the overwrite?

When I built the last Windows installer, I hacked the pyTivo code to look for the conf file in the Shared Documents area. wmcbrine's pyTivo fork only looks for the conf inside the pyTivo program folder by default. There is an option to specify it on the command line also, but I haven't updated the Windows installer to use that.

So if having a pyTivo.conf in the Shared Documents folder works for you, then you definitely did not update the code fully.
Back to top
View user's profile Send private message
brennok



Joined: 08 May 2010
Posts: 15

PostPosted: Thu May 13, 2010 12:35 am    Post subject: Reply with quote

I have no idea. I just tried it on another Win 7 ultimate 64 bit machine just built the other night with same results. There must be something I am reading/interpreting wrong without realizing it. The service also wasn't started. I even started and then stopped the service before proceeding.

The only thing I am doing differently is the extraction of the latest wmcbrine fork since when it extracts it automatically does so into its own folder so it doesn't overwrite anything. I am also skipping the photo plugin.

When I finish I can't see any shares at all including the one I setup during the install.

EDIT: looking at the copied pytivo.conf file it contains the temp= line where you move the file from. There isn't a pytivo.conf file in the wmcbrine zip so this file doesn't get overwritten. Could this be why it is still looking for the conf file in the temp directory?
Back to top
View user's profile Send private message
orangeboy



Joined: 14 Sep 2009
Posts: 74

PostPosted: Fri Jul 02, 2010 12:27 am    Post subject: Reply with quote

This needs stickied.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Site is in NO WAY affiliated with TiVo Inc

Powered by phpBB © 2001, 2005 phpBB Group
phpBB SEO

Get pytivo at SourceForge.net. Fast, secure and Free Open Source software downloads
[ Time: 2.0798s ][ Queries: 12 (0.0097s) ][ GZIP on - Debug on ]