pyTivo Discussion Forum Forum Index pyTivo Discussion Forum
Answers and the development of pyTivo a TiVo transcoding server
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Permission Denied

 
Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support
 View previous topic :: View next topic  
Author Message
YellowDog



Joined: 04 Jul 2009
Posts: 1

PostPosted: Sat Jul 04, 2009 5:45 pm    Post subject: Permission Denied Reply with quote

I just installed Python and pytivo. I did not install pytivo as a service.

When I start the pytivo console from the the Startup menu, I get the following error:

IOError: [Errno 13] Permission denied: 'C:\\Program Files\\pyTivo\\debug.log'

The logon account I'm using on this Vista machine is an admin. The file debug.log does not exist.

I also tried this command from the command line:

c:\"program files"\python62\python c:\"program files"\pytivo\pytivo.py

I got path not found although I'm pretty sure that they're there.

Also, if I enter this URL in the browser: http://localhost:9032/ I get a "cannot locate the server" message.

I did a search through this message board for these errors but found nothing relevant.

Any help?
Back to top
View user's profile Send private message
rdian06



Joined: 12 Apr 2008
Posts: 1420

PostPosted: Sat Jul 04, 2009 6:12 pm    Post subject: Re: Permission Denied Reply with quote

YellowDog wrote:
I just installed Python and pytivo. I did not install pytivo as a service.

When I start the pytivo console from the the Startup menu, I get the following error:

IOError: [Errno 13] Permission denied: 'C:\\Program Files\\pyTivo\\debug.log'

The logon account I'm using on this Vista machine is an admin. The file debug.log does not exist.

I also tried this command from the command line:

c:\"program files"\python62\python c:\"program files"\pytivo\pytivo.py

I got path not found although I'm pretty sure that they're there.

Also, if I enter this URL in the browser: http://localhost:9032/ I get a "cannot locate the server" message.

I did a search through this message board for these errors but found nothing relevant.

Any help?


Which installer did you use? The latest one 3-19 moves the debug.log file to a new location to avoid that permissions issue.

Also make sure you do NOT have a pyTivo.conf file in the pyTivo folder. The 3-19 installer moves the conf file elsewhere. Start with the basic one (there's a start menu link to reveal the new location) and customize as needed.

BTW, on Vista with UAC enabled, running from an account that has admin privileges doesn't by itself give you the ability to write to program files folders. You have to elevate privileges when running the program by right clicking and choosing "Run as Administrator". In this case you would right click on the pyTivo start on console shortcut on the start menu.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Site is in NO WAY affiliated with TiVo Inc

Powered by phpBB © 2001, 2005 phpBB Group
phpBB SEO

Get pytivo at SourceForge.net. Fast, secure and Free Open Source software downloads
[ Time: 0.0484s ][ Queries: 12 (0.0064s) ][ GZIP on - Debug on ]