pyTivo Discussion Forum Forum Index pyTivo Discussion Forum
Answers and the development of pyTivo a TiVo transcoding server
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Installation issues Ubuntu 9.10

Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support
 View previous topic :: View next topic  
Author Message

Joined: 19 Jan 2009
Posts: 2

PostPosted: Fri Nov 06, 2009 2:07 pm    Post subject: Installation issues Ubuntu 9.10 Reply with quote

New (effectively) to pyTivo.
Downloaded latest wmcbrine-8a2fa39eb47a28e60fc6caf6727d6d5c8bb027f7.tar.gz
Followed Ubuntu 9.10 instructions to download "extra" version of ffmpeg
ffmpeg -v says:
FFmpeg version SVN-r19352-4:0.5+svn20090706-2ubuntu2, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --extra-version=4:0.5+svn20090706-2ubuntu2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --extra-cflags=-I/build/buildd/ffmpeg-0.5+svn20090706/debian/include --enable-shared --disable-static
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 0 / 52.20. 0
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 4. 0 / 0. 4. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Oct 13 2009 22:15:16, gcc: 4.4.1



type = video
path = /home/chrisb/Videos/tivo


debug = False
port = 9032
ffmpeg = /usr/bin/ffmpeg

I have two issues:
1. I don't see any ToGo functionality. When I pull up http://localhost:9032/ all I get is the Web Configuration link. Should I be seeing more there?
2. From my TiVO HDXL I can see my share fine, and I can transfer and view SD programs fine. These are .tivo files that were transferred via TiVo Desktop to Windows and then copied to my Ubuntu machine/share. I can't transfer HD programs. They either come up as being copy protected when I see info about them, or if I can see info about them and start a transfer, all I get is a 0:00 recording on my TiVo. All these shows transfer fine from my Windows machine.

I see no errors when I turn debugging on.

Given my lack of ToGo functionality, I suspect I'm missing something basic about the setup.
Back to top
View user's profile Send private message

Joined: 12 Apr 2008
Posts: 1420

PostPosted: Fri Nov 06, 2009 4:05 pm    Post subject: Reply with quote

The ToGo functionality is hidden until you add tivo_mak with your Tivo MAK and togo_path with the path to store togo downloads to the Server section of your conf.

Likewise, if you want to use the Push capability you need to add your tivo_username and tivo_password with your account info into the Server section of your conf.
Back to top
View user's profile Send private message

Joined: 04 Jan 2008
Posts: 2622
Location: Maryland

PostPosted: Fri Nov 06, 2009 6:44 pm    Post subject: Reply with quote

Re: the untransferrable files, I was persuaded a while back that ffmpeg could still extract the info (resolution, duration, etc.) from an encrypted .TiVo file, and that I could therefore drop the special-casing that was being done for those files. This has since proven to be only partly true, depending on the version of ffmpeg. I've already added some special-casing back, and I may have to do more. Sad

Meanwhile, you can improve pyTivo's handling of .TiVo files (though I don't think it will help this specific problem) by building yourself a copy of tivodecode, and putting it (and the accompanying tdcat) into the PATH, or into pyTivo's bin directory. And once you have tivodecode, you can (manually) decrypt the .TiVo files to more usable .mpg's, which pyTivo should then have no problem with. Use to create .txt files from the .TiVo files' metadata:

tivodecode -m your_mak -o file.mpg file.TiVo
/path/to/pytivo/ file.TiVo > file.mpg.txt

I can provide 64-bit binaries of tivodecode for Ubuntu if needed.

My pyTivo fork . My page
Back to top
View user's profile Send private message Visit poster's website

Joined: 19 Jan 2009
Posts: 2

PostPosted: Sat Nov 07, 2009 6:05 pm    Post subject: Reply with quote

Many thanks to both of you! I spent several hours last night, and then again this morning and I don't know of anything that isn't working right now. Both push and pull are working.

However, the hours have been full of mysteries - things that did work then stopped working for a while and then worked again, and things that didn't work were all of a sudden working again. It's clear throughout the process that I needed to restart pyTivo a lot more often than I actually did - Linux file system changes (renamed files and modes) caused lots of problems because old values were cached.

What can cause a "Error - 503 Try Transfer Again" error when using ToGo? The sequence of events was
0. TiVo1 had succeeded at ToGo to Ubuntu box last night. This morning:
1. checked to make sure Tivo1 was not transferring anything.
2. 3 attempts at transfer a show from TiVo1 to Ubuntu box failed, with 503 error.
3. Attempts to transfer shows from TiVo2 and TiVo3 to Ubuntu both succeeded.
4. Attempt to transfer show from TiVo1 to WindowsPC using TiVo Desktop succeeded.
5. Attempt to transfer show for TiVo1 to Ubuntu succeeded! (had one show that failed in step2, succeeded in step 4, and then succeeded now in step 5).

Is there anything I should look at to figure this out? For now, I'm just chalking it up as another mystery. It shouldn't be a network problem - everything is hardwired and TiVo1 and TiVo2 are even on the same switch. Is there a significant time lag on a TiVo after an MRV transfer ends before another transfer can happen?

Some of my initial "copy protection" problems were actually copy protection problems and not ffmpeg deciphering problems, so I'm not sure you need to revisit that. (When moving files from Windows to Ubuntu, I had made some files mode 0 to avoid overwriting and forgot to change them back.) I'm still not sure what caused the 0:00 length problems, but those disappeared early on - possibly due to tivodecode making it into my path, possibly due to push and pull getting set up correctly.

One very minor bug - I explicitly used tivodecode to convert an HD show. To my surprise, the resulting mpg was listed as downloadable when viewed from an S2. The download succeeded, but the resulting show just had audio with a black screen (not surprising - the minor bug is that it was marked as downloadable in the first place).

Again, thanks for your responses.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    pyTivo Discussion Forum Forum Index -> Support All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Site is in NO WAY affiliated with TiVo Inc

Powered by phpBB © 2001, 2005 phpBB Group

Get pytivo at Fast, secure and Free Open Source software downloads
[ Time: 0.0955s ][ Queries: 13 (0.0145s) ][ GZIP on - Debug on ]